it was not possible to start a SSL encrypted connection via this

Recommend this page to a friend!

      PHP HTTP protocol client  >  All threads  >  it was not possible to start a SSL...  >  (Un) Subscribe thread alerts  
Subject:it was not possible to start a SSL...
Summary:it was not possible to start a SSL encrypted connection via this
Messages:7
Author:allenmao
Date:2015-04-29 01:47:35
 

  1. it was not possible to start a SSL...   Reply   Report abuse  
Picture of allenmao allenmao - 2015-04-29 01:47:35
hi

i setup $proxy_host_name="xx.xx.xx.xxx";and $proxy_host_port=8080;in the http.php

and when i run it, it says,

it was not possible to start a SSL encrypted connection via this proxy

can i fix it please?

  2. Re: it was not possible to start a SSL...   Reply   Report abuse  
Picture of Manuel Lemos Manuel Lemos - 2015-04-29 02:04:00 - In reply to message 1 from allenmao
That means that the remote server is not accepting SSL 2 or 3 connections. Maybe it requires TLS. What is the address of the remote server you want to connect?

  3. Re: it was not possible to start a SSL...   Reply   Report abuse  
Picture of allenmao allenmao - 2015-04-29 02:19:05 - In reply to message 2 from Manuel Lemos
10.33.4.132

i tried

STREAM_CRYPTO_METHOD_SSLv23_CLIENT

or

STREAM_CRYPTO_METHOD_TLS_SEVER

i didn't work

  4. Re: it was not possible to start a SSL...   Reply   Report abuse  
Picture of Manuel Lemos Manuel Lemos - 2015-04-29 02:25:46 - In reply to message 3 from allenmao
I did not mean the proxy server, I mean the actual Web server you want to connect.

  5. Re: it was not possible to start a SSL...   Reply   Report abuse  
Picture of allenmao allenmao - 2015-04-29 02:55:42 - In reply to message 4 from Manuel Lemos
Resolving HTTP server domain "api.linkedin.com"...
Connecting to HTTP server IP 103.20.92.132 port 443...
OAuth client: Error: it was not possible to open the OAuth request token URL: 110 could not connect to the host "api.linkedin.com"
error: it was not possible to open the OAuth request token URL: 110 could not connect to the host "api.linkedin.com"

  6. Re: it was not possible to start a SSL...   Reply   Report abuse  
Picture of Manuel Lemos Manuel Lemos - 2015-04-29 03:20:48 - In reply to message 5 from allenmao
It seems you are not setting the proxy variables correctly because it is connecting directly the LinkedIn server.

What code are you using to setup the proxy server.

  7. Re: it was not possible to start a SSL...   Reply   Report abuse  
Picture of allenmao allenmao - 2015-04-29 03:35:37 - In reply to message 6 from Manuel Lemos
my solution:

//modify http.php

$proxy_host_name="";
$proxy_host_port = 80;

set $protocol= "https";
set $prefer_curl = 1;

thanks bro.!!


hit:
line 670
$ssl=(strtolower($this->protocol)=="https" && strlen($this->proxy_host_name)==0);

 

For more information send a message to info at phpclasses dot org.